


UNIT - I
Introduction to Computer systems and Hardware

1. What is a Computer?
A. A computer can be described as an electronic calculating device that accepts raw data as input, processes it and produces meaningful information as an output. 
A computer system is made up of both hardware and software components.
Computer
input

output

[image: ] [image: ]
storage

2. What are the components used in Second generation computers?
A. In second generation starts the Manufacturers of IBM 7030, Digital Data Corporation’s PDP 1/5/8 Honeywell 400 and Transistors were used in place of vacuum tubes.
3. What are the types of computers based on purpose?
A.  Based on purpose computers are classified in to 2 types. They are:
           1.General purpose computers.
           2.Special purpose computer.
4. What are the types of computers based on operation?
A. Based on OPERATION SIZE of computers are classified in to 3 types. They are:
1.Analog Computers
2.Digital Computers
3.Hybrid Computers
5. What are the different number systems?
A. Basically Number system is divided in to four types.

1.Binary Number System
2.Octal Number system
3.Decimal Number system
4.Hexa-decimal Number System
6. Convert (22)10 into (?)2
A. 
	2
	22
	Remainder

	2
	11
	0 (LSB)

	2
	5
	1

	2
	2
	1

	2
	1
	0






	(22)10 = (10110)2

7. Convert (44)10 into (?)8
A. 
    
	8
	44
	Remainder

	8
	5
	4 (LSB)


  


(44)10 = (54)8

8. Convert (43)10 into (?)16
A. 
	16
	43
	Remainder

	16
	2
	11 (LSB)




	
	(43)10=(2B)16
9. Convert (1110)2 into (?)10
A.                
                      	= 1x23 + 1x22 + 1x21   + 0x20
                     	= 8 +4+2
     			= (14 )10
10. Convert (25)8 into (?)10
A. 
= (2 x 81) + (5 x 80)
= (2 x 8) + (5 x 1)
= 16+5
= (21)10
11. Convert (2A)16 into (?)10
A. 
= (2 x 161) + (A x 160)
= (2 x 16) + (10 x 1)
= (42)10
12. Convert (420)8 into (?)2
A.   step 1:
= (4 x 82) +(2 x 81) + (0 x 80)
= (4 x 64) +(2 x 8)
= 256+16
= (272)10
Step 2:
	Division
	Quotient
	Remainder
(Digit)
	Digit #

	272/2
	136
	0
	0

	136/2
	68
	0
	1

	68/2
	34
	0
	2

	34/2
	17
	0
	3

	17/2
	8
	1
	4

	8/2
	4
	0
	5

	4/2
	2
	0
	6

	2/2
	1
	0
	7

	1/2
	0
	1
	8














= (100010000)2


13. Convert (FF)16 into (?)2
A.   (1515) 16
	2
	15
	Remainder

	2
	7
	1 (LSB)

	2
	3
	1

	2
	1
	1


	


	2
	15
	Remainder

	2
	7
	1 (LSB)

	2
	3
	1

	2
	1
	1






   (FF)16 = (11111111)2
14. Convert (101010)2 into (?)8
A. 
Base 2 to decimal calculation:
(101010)2 = (1 × 25) + (0 × 24) + (1 × 23) + (0 × 22) + (1 × 21) + (0 × 20) = (42)10
Decimal to base 8 calculation:
Divide by the base to get the digits from the remainders:
	Division
	Quotient
	Remainder
(Digit)
	Digit #

	42/8
	5
	2
	0

	5/8
	0
	5
	1


= (52)8

15. Convert (101110)2 into (?)16
A. 
 Base 2 to decimal calculation:
(101110)2 = (1 × 25) + (0 × 24) + (1 × 23) + (1 × 22) + (1 × 21) + (0 × 20) = (46)10

Decimal to base 16 calculation:
Divide by the base to get the digits from the remainders:
	Division
	Quotient
	Remainder
(Digit)
	Digit #

	46/16
	2
	14
	0

	2/16
	0
	2
	1


= (2E)16

16. Convert(3D)16 into (?)8
A.
Base 16 to decimal calculation:
(3D)16 = (3 × 161) + (13 × 160) = (61)10

Decimal to base 8 calculation:
Divide by the base to get the digits from the remainders:
	Division
	Quotient
	Remainder
(Digit)
	Digit #

	61/8
	7
	5
	0

	7/8
	0
	7
	1


= (75)8
17. Convert (125)8 into (?)16
A.
Base 8 to decimal calculation:
(125)8 = (1 × 82) + (2 × 81) + (5 × 80) = (85)10

Decimal to base 16 calculation:
Divide by the base to get the digits from the remainders:
	Division
	Quotient
	Remainder
(Digit)
	Digit #

	85/16
	5
	5
	0

	5/16
	0
	5
	1


= (55)16

18. Why binary numbers are used in computers.
A. Computer is an electronic device which can understand any instruction given to it in a binary coded form (0 or 1).  A program written in binary form is called as machine language.
           Example: 11000000000000011000010011000000000001000
19. Define input device.
A. An input device sends information to a computer system for processing. An input device can send data to another device, but it cannot receive data from another device. Instances of an input t device include:
		1. Keyboard
		2. Mouse
		3. Scanner
		4. Joystick
		5. Light pen.
20. Define output device.  
A. Which can send data (input) to the computer, but they cannot receive or replicate information (output) from the computer. Which can receive data (output) from the computer, but they cannot send information (input) to the computer.
		Ex:
			1.Mnitor
			2.Printer
			3.Speakers.
21. Write the names of two input and two output devices.
A. Input Devices:
		1. Keyboard
		2. Mouse
		3. Scanner
		4. Joystick
		5. Light pen.
   Output devices:
		1.Mnitor
		2.Printer
		3.Speakers.
22. What is a scanner?
A. The scanner is an input device used for direct data entry from the documents into the computer. It translates the document image into digital form so that it can be stored into the computer.
23. What is a light pen?
A.      It is a pen shaped input device used to select objects on a display screen. It is relatively like the mouse in functionality but uses a light pen to move the pointer and select any object on the monitor by pointing to the object. 
         The Users of Computer Aided Design (CAD) applications commonly use the light pens to directly draw on screen.
24. What is a printer and printout?
A. Printers are used to generate paper (commonly known as hardcopy) output.  
     Printer is used to print the require data on printer. The printed copy is known as printout or hard copy.
25. Distinguish between bit and byte.
A. In memory a single storage cell is called Bit and within one cell stores either 1 or 0 only. Which stands for one binary piece of information.
	The difference between a bit and a byte is size, or the amount of information stored.
26. Define volatile and non-volatile memory.
A.        volatile memory: the data in RAM available there only as long as the computer is running. When the computer turned off, the data in RAM is lost.
          non-volatile memory: even when the computer is turned off, the contents of ROM remain available. It is a permanent memory because once we write any data in the ROM those are remaining unchanged in memory.
27. how many bytes for 1 GB memory?
A. 
	1GB =1024*1024*1024*8
=233
=8589934592 bits
28. Expand RAM, ROM, PROM and EAPROM
A. 	RAM: Random Access Meory
	ROM: Read Only Memory
	PROM: Programmable Read Only Memory
	EAPROM: Electrically Alterable Read Only Memory
29. Write the names auxiliary storage devices.
A. 	1. Magnetic Tape
	2. Magnetic disk
	3. Hard Disk
	4. Floppy disk
30. What is cache memory?
A. Cache memory is a chip-based computer component that makes retrieving data from the computer's memory more efficient. 
     It acts as a temporary storage area that the computer's processor can retrieve data from easily. This temporary storage area, known as a cache.
31. What are registers?
A. Processor contains a number of high speed storage elements called Registers. These registers are used for temporary storage of frequently used operands.
32. What is software and hardware?
A. Software: Software refers to the set of computer programs, procedures that defines the programs. Software guides the PC at every step where to start and halt during a specific job. The process of software development is called programming.
        Hardware: The physical parts, which you can see and touch, are collectively called hardware. It is the machine itself and its several individual equipment.
33. What is computer Language?
A. The processes of a computer are controlled by a set of instructions called a computer program. The set of instructions to construct a program is called programming language.
34. Name the three different categories of computer languages.
A. There are two major types of programming languages. These are                                               
                 Low Level Languages and                
                 High Level Languages. 
Low Level languages are additional divided into 
                 Machine language and 
                 Assembly language.
35. What is machine language? Why is it required?
[bookmark: _Hlk71647720]A.    Computer is an electronic device which can understand any instruction given to it in a binary coded form( 0 or 1).  
       A program written in binary form is called as machine language.
Example: 11000000000000011000010011000000000001000
36. What are advantages and disadvantages of machine language .
A. Advantages
1. Execution speed is very fast
2. Efficient use of primary memory
3. It does not need any translation because machine code is directly understood by the computer.
Disadvantages
1. Writing a program in machine language is a very difficult.
2. Every machine has its own machine language.
3. Error prone
4. Difficult to modify
37. What is assembly language? What are its advantages over machine languages?
A.         In assembly language, the instructions are written by mnemonics (symbols) to shorten the program.
Advantages
1. Easier to memorize and use: Assembly language program is easy to use,understand and memorize because it uses mnemonic codes in place of binary codes.
2. Easy to write input data: In assembly language programs the input data can bewritten in decimal number system, later they are converted into binary.

38. What is the difference between source program and object program?
A. The programs written by the programmer in higher level language is called source program and after this program is transformed to machine languages by the compiler it is called object program.
39. What is higher level languages? Why are higher level languages are easier to use.?
A. Higher level languages are problem-oriented languages because the instructions are suitable for solving a particular problem.
      In High level language, instructions are written using natural language such as English and mathematical symbols like +, -, %, / etc.
      Therefore it is easy to write and understand High level language programs than Assembly language programs and machine language programs.
40. What is compiler? Why is it required?
A. It is a program translator that translates the instruction of a higher level language to machine language. Thus compiler is a program translator like assembler but more refined. It takes the total program one at time and translates into low level language.
High Level Language Program
Compiler

(Translator)
Machine language


41. What is interpreter? How does it differ from compiler?
A. An interpreter is one more type of program translator used for converting higher level language into machine language. It takes one statement of higher-level languages, convert it into machine language and directly execute it.
42. What is an utility?
A. A program that does a specific task related to the organization of computer functions, resources, or files, as password protection, memory management, virus protection, and file compression.
43. What is a virus?
A. A virus is a program that replicates itself. It spread by creatingcopies of itself on a computer or by inserting computer code into program or operating system files.
44. What is a worm?
A.    An unwanted computer program that duplicates itself through a computer network. Most worms begin as e mail attachments that infect a computer when they’re opened.
45. What is Trojan horse?
A. A Trojan horse is a malicious software program that hides inside other programs. It enters a computer hidden inside a genuine program, such as a screen saver or any other genuine software.
46. What is blended threat?
A. A blended threat is a mixture of some or all of the malicious programs discussed in the sections above. Blended threats often begin when someone interacts with a virus.
Long Answer Type Questions
1. Write about the generations of computers.
A.   Generations of computer system:
	Generations of computers has been divided into five generations.

I Generation: 1945 – 55

II Generation: 1955 – 65

III Generation: 1965 – 75

IV Generation: 1975 – 89

V Generation: 1989 to present

First Generation
In first generation ENIAC (Electronic Numerical Integrator And Calculator), EDSAC (Electronic Delay Storage Automatic Calculator), Vacuum tubes were used to perform basic arithmetic operations and it took few milliseconds
Characteristics of first generation computers:
1. Bulky
2. Consume more power with limited performance
3. High cost
4. Fixed point arithmetic was used
5. Punched cards and paper tape were invented to feed programs and data and to get results.
6. Magnetic tape / magnetic drum were used as secondary memory
7. Mainly used for scientific computations.
Second Generation
In second generation starts the Manufacturers of IBM 7030, Digital Data Corporation’s PDP 1/5/8 Honeywell 400 and Transistors were used in place of vacuum tubes.
Characteristics of second generation computers:
1. Small in size
2. Lesser power consumption and better performance Lower cost

Third Generation
In Third Generation System 360 Mainframe from IBM, PDP-8 Minicomputer from Digital Equipment Corporation is designed with Integrated circuits. Small Scale Integration and Medium Scale Integration technology were implemented in CPU, I/O processors etc.
Characteristics of third generation computers:
1. Smaller & better performance
2. Comparatively lesser cost
3. Faster processors
4. In the beginning magnetic core memories were used. Later they were replaced by semiconductor memories (RAM & ROM).
5. Introduced	microprogramming, Microprogramming, parallel processing,  multiprogramming, multi-user system etc. was introduced.

Fourth Generation:
In Fourth Generation Microprocessors were introduced as CPU– Complete processors and large section of main memory could be implemented in a single chip.
Characteristics of fourth generation computers:
1. Tens of thousands of transistors can be placed in a single chip (VLSI design implemented)
2. CRT screen, laser & ink jet printers, scanners etc were developed.
3. Semiconductor memory chips were used as the main memory.

Fifth Generation

In Fifth Generation, IBM notebooks, Pentium PCs-Pentium 1/2/3/4/Dual core/Quad core.. SUN work stations, Origin 2000, PARAM 10000, IBM SP/2 are used occasionally to describe some current computer system that have a dominant organizational or application driven feature.

Characteristics of fifth generation computers:

1. Computers based on artificial intelligence are available
2. Computers use extensive parallel processing, multiple pipelines, multiple processors etc.
3. Introduced ULSI (Ultra Large Scale Integration) technology – Intel’s Pentium 4 microprocessor contains 55 million transistors millions of components on a single IC chip.
4. Superscalar processors, Vector processors, SIMD processors, 32 bit micro controllers and embedded processors, Digital Signal Processors (DSP) etc. have been developed.

2. Explain the characteristics of computers.
A. 
Characteristics (Features) of Computer 
The main characteristics or features of computer are listed as under. They are: 
 Speed 
 Accuracy (Perfect ness) 
 Diligence 
 Versatility 
 Power of Remembering. 
 No I Q 
 No feelings 
 Storage
Speed:
           The computer is a fast device; it can perform a task in a few seconds that a human being does in an entire year. Powerful computers can capable of performing about 3 to 4 billion simple arithmetic operations per second. 
Accuracy 
            The accuracy is one of the most important features in computer. Accuracy means the computer is always perfect in his work and he never makes mistakes.
Diligence 
              Unlike human beings, the computer is free from monotony tiredness like lack of concentration. Hence, the computer can work for many hours without creating any error and without grumbling. 
Versatility 
               Versatility is one of the most wonderful things in computer. It can do multiple jobs at a time. 
Power of Remembering. 
                 In computer, we can store any type and any amount of information and we can retrieve the same information after the several years because of its storage capability. Therefore, the remembrance capacity of computer is so high. 
No, I Q 
               (Intelligence Quotient) The computer I Q is a big zero because it cannot think like human beings and it cannot take decision. It cannot find any error in a data and it cannot correct such errors. 
No Feelings 
               The computer is not having any feelings like human beings because it is a machine. It will do the task, what the user commands to it. 
Storage 
             By default, the user data in a computer stores in secondary storage device (hard disk). We can store any amount of data based on the storage device capacity.
3. Explain various computers based on purpose.
A. The computer systems are classified into various types depends on their usage of the computer, operations done in the computers and their sizes. They are
1. [bookmark: _Hlk71550218]General purpose computers.

2. Special purpose computer.

General Purpose Computers: 
          These computers are generally used for any type of applications. These computers can be used in solving day to day small business applications and also used to solve mathematical equation with same accuracy and consistency. 
        Today’s Most of the computers are used in household purpose are general purpose digital computers.
Special Purpose Computers:
          These digital computers are designed, made and used for any specific job. These are frequently used for those purposes. Which are serious and essential great accuracy and response like Satellite launching.
4. Explain various computers based on operation (3 marks)?
A.          According to the operational principle of computers, they are divided into analog, digital and hybrid computers.
[bookmark: _Hlk71550630]Analog Computers: These are nearly extinct today. These are unlike from a digital computer because an analog computer can do several mathematical operations simultaneously. It uses continuous variables for mathematical operations and utilizes mechanical or electrical energy.
[bookmark: _Hlk71550645]Digital Computers: They use digital circuits and are designed to operation two states, namely bits 0 and 1 and they are analogous to states ON and OFF. Data on these computers is denoted as a series of 0s and 1s.
[bookmark: _Hlk71550659]Hybrid Computers: These computers are a mixture of both digital and analog computers. In this type of computers, the digital sections perform process control by transformation of analog signals to digital ones.
5. Explain various computers based on size. (6 marks)
A. Based On the sizes of the computers, the computers are classified as follows.
Supercomputers: The extremely calculation-intensive tasks can be effective Lydon by means of supercomputers. Quantum physics, mechanics, weather forecasting, molecular theory are best calculated by means of supercomputers.
		Ex. PARAM developed in India.
Servers: They are computers designed to offer services to client machines in a computer network. They have bigger storage capacities and powerful processors. They are designed to be fail-safe and resistant to crash.
Mainframe Computers: Huge organizations use mainframes for highly serious applications such as bulk data processing and ERP. 
          Most of the mainframe computers have abilities to host multiple operating systems and operate as several virtual machines. 
Wearable Computers: A record-setting step in the progress of computers was the creation of wearable computers. 
       These computers can be worn on the body and are often used in the study of behavior modelling and human health.
Minicomputers: In terms of size and processing capacity, minicomputers lie in between mainframes and microcomputers. Minicomputers are also named mid-range systems or workstations. 
Microcomputers: A computer with a microprocessor and its central processing unit is known as a microcomputer. They do not occupy space as much as mainframes do. When supplemented with a keyboard and a mouse, microcomputers can be named personal computers.
Desktops: A desktop is planned to be used on a single location. The spare parts of a desktop computer are freely available at relatively lower costs. Desktops are commonly popular for daily use in the workplace and households.
Laptops: Similar in operation to desktops, laptop computers are reduced and optimized for mobile use.
6. Draw the Block diagram of digital computer and explain each unit neatly.
A. [image: Diagram

Description automatically generated]

The Computer system majorly consists four basic functional units
1. Input unit,
2. Processor unit
3. Output
4. Storage.
INPUT UNIT
            This is the process of entering data and programs into the computer system. Therefore, the input unit takes data from us to the computer in an organized manner for processing through an input device such as keyboard, mouse, MICR, OCR, Etc.
PROCESSOR UNIT
           The heart of the computer system is the Processor unit. It consists two major components.
1. Arithmetic and Logic Unit
2. Control Unit.
OUTPUT UNIT
           This is the process of producing results from the data for getting useful information. E.g. Printer, Video terminals (provides both input & output functions), graphic displays etc.
MEMORY UNIT
The memory unit stores program and data. There are two classes of memory devices:-

1. Primary memory
2. Secondary memory.
7. Write about number systems.
A. Generally, the following four types of number systems are used to represents the data.
[bookmark: _Hlk71550899]Basically Number system is divided in to four types
1. Binary Number System
2. Octal Number system
3. Decimal Number system
4. Hexa-decimal Number System

Binary Number System:- It is base(radix) of 2 and it has only two di its i.e 0 and 1 for representing any number. The value of the numbers is represented as power of 2 i.e. the radix of the system. These power increases with the position of the digits as  follows
 (
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Description automatically generated] 







Ex: 11001(2)
Octal Number System :- It is base of 8 and it has only eight digits { 0 ,1,2,3,4,5,6 ,7} for representing any number. The value of the numbers is represented as power of 8. These power increases with the position of the digits as follows.
[image: Table, calendar

Description automatically generated]Ex : (25)8
Decimal Number System :- It is base of 10 and it has only ten digits { 0,1,2,3,4,5,6 ,7,8,9} for representing any number. The value of the numbers is represented as power of 10. These power increases with the position of the digits as follows
[image: ]

EX: (256)10
Hexa Decimal Number System: - It is base of 16 and it has only ten digits {0,1,2,3,4,5,6,7,8,9, A,B,C,D,E,F} for representing any number. The value of the numbers is represented as power of 16. These power increases with the position of the digits as follows.

[image: ]

EX: (2A2)16
8. Write about input devices.
A. Keyboard: it is one of the major hardware components in computer system. It is a text base input device and it allows the user to input alphabets, numbers and other characters. It consists several keys on a board to give data.
Mouse: The mouse is used to point to a specific place on the screen and select in order to perform one or more activities. It can be used to select menu, menu sub menu, size windows, start programs etc.
Joystick: The joystick is a vertical stick which moves the graphic cursor in the monitor in a way the stick is moved. Joystick is used as an input device mainly used with video games, training simulators and controlling robots
[bookmark: _Hlk71649999]Scanner: The scanner is an input device used for direct data entry from the documents into the computer. It translates the document image into digital form so that it can be stored into the computer.
[bookmark: _Hlk71650094]Light Pen: It is a pen shaped input device used to select objects on a display screen. It is relatively like the mouse in functionality but uses a light pen to move the pointer and select any object on the monitor by pointing to the object. The Users of Computer Aided Design (CAD) applications commonly use the light pens to directly draw on screen.
Touch Screen:  It allows the user to operate selections by simply touching the display screen. Common examples of touch screen include information smart phones and bank ATMs.
The Speech Input Device: The “Microphones - Speech Recognition” is a speech Input device. To operate it we need using a microphone to talk to the computer.
9. Write about output devices.
A. Monitor: Monitor or screen is an output device that looks like the television screen and uses a Cathode Ray Tube (CRT) to display information. 
                    The monitor is associated with a keyboard for manual input of characters and displays the data as it is keyed in. It also displays the program or application output. Like the television, monitors are also available in various sizes.
Liquid Crystal Display (LCD): LCD was announced in the 1970s and is now useful to display terminals also. Its benefits like low energy consumption, smaller and lighter have paved its way for usage in portable computers (laptops).
[bookmark: _Hlk71650430]Printer: Printers are used to generate paper (commonly known as hardcopy) output. Based on the technology used, they can be categorized as Impact or Non-impact printers.
Plotter:  Plotters are used to print graphical output on paper. It interprets computer commands and makes line drawings on paper using multi-colored automated pens. It is capable of producing graphs, drawings, charts, maps etc.
Audio Output: Sound Cards and Speakers: The Audio output is the capability of the computer to output sound and it need Two components that they are Sound card – Plays contents of digitized recordings, Speakers – Attached to sound card.
10. Write about primary memory and secondary memory.
A. The memory unit stores program and data. There are two classes of memory devices :-
Primary memory
Secondary memory.
Primary memory: Primary memory is also called as Main memory and it contains a large number of semiconductor cells. 
            Each cell having capable of storing one bit of information. These cells in memory are processed in group of fixed size called WORD with ‘n’ bit length.
	    distinct address is associated with each word location and before executing a program.
	    Fast memory Expensive Time required to access one word is called Memory Access Time - 10nS to 100nS. 
             This time is fixed and independent of the location.
	    Once turn off the computer system the data stored with in the memory are lost. 
                   E.g. Random Access Memory (RAM)
Secondary storage:
           They are used when large amount of data have to be stored permanently in memory It is also known as auxiliary memory. It is closely linked with the main memory.
          Thus secondary storage is used to hold mass of information i.e., system software, application programs, cinemas, games and data files.
           Obviously the capacity of secondary storage is very high compared to main memory. 
           Auxiliary memory usually in the form of Magnetic disk, Magnetic tape, CD’s, Memory cards, Pen drives, Compact Disk, Floppy Disk Etc.,
11. Write about secondary storage devices.
A. Often it is required to store a huge number of bytes of data for the CPU to process. Therefore, additional memory is required in all the computer systems. This memory is called auxiliary memory or secondary storage. In this type of memory.
[bookmark: _Hlk71712241]Magnetic Tape
         Magnetic tapes are used for large computers similar to mainframe computers where large volume of data is stored for a longer time. In computer system also you can use tapes in the form of cassettes.Tapes consist of magnetic materials that store data permanently. It can be 12.5 to 25 mm wide plastic film-type and 500 meter to 1200 meter long.
[bookmark: _Hlk71712342]Magnetic disk
          A Magnetic disk is a circular plate built of metal (or) plastic coated with magnetized material. Regularly the two sides of the disc are utilized and some discs may be used on one spindle with read/write heads available on each surface. The tracks are usually partitioned into sections called sectors.
Magnetic disks are of two types.

[bookmark: _Hlk71712379]        Hard disk: Disks that are permanently attached to the unit assembly and cannot remove by the occasional user are called hard disks.
[bookmark: _Hlk71713874]        Floppy disk: A disk drive with removable disks is called a floppy disk.

Optical Disk: With each application and software there is more demand for memory capacity. It is the want to store large volume of data that has managed to the development of optical disk storage medium. Optical disks can be divided into the following categories.
        Compact Disk/Read Only Memory (CD-ROM): CD-ROM disks are made of reflective metals. CD-ROM is written during the process of manufacturing by high power laser beam.
      Write Once Read Many (WORM): The inconvenience that we cannot write anything into a CD-ROM is avoided in WORM. A WORM allows the user to write data permanently on the disk.
       Erasable Optical Disk: These are optical disks where data can bewritten, erased and re- written. This also applies a laser beam to write and re-write the data.
Flash drive:
	Flash drives have many names - jump drives, thumb drives,pen drives, and USB keychain drives. Regardless of what you call them, they all refer to the same thing, which is a small data storage device that uses flash memory and has a built-in USB connection.
          Nowadays flash drives can store several gigabytes of information. Since they are small in size but have large storage capacities.
12. Write about RAM and ROM.
A. In computer system majorly uses two different types of main memories, they are

a)   Random access memory (RAM)
                             b)   Read only memory (ROM)
Random access memory: 
 The primary storage is denoted as Random Access Memory (RAM) because it is potential to randomly select and use any location of the memory directly to store and retrieve data. 
             It takes same time to any address of the memory as the first address. 
             The user has direct access to this part of memory i.e., the user can read and can write into this memory. 
[bookmark: _Hlk71710652]            Hence this memory is also known as Read / writes memory.                  Main memory combines 1 or more bytes into a single unit which is called word. 
          It is volatile in nature i.e., the data in RAM available there only as long as the computer is running. When the computer turned off, the data in RAM is lost.
                     RAM is of two different types.
1. Static RAM
2. Dynamic RAM
Read – Only Memory(ROM)
[bookmark: _Hlk71710962]               In this portion of memory some instructions are permanently loaded during the manufacturing of the computer system.                                                                                                    ROM is non-volatile memory because even when the computer is turned off, the contents of ROM remain available. 
            It is a permanent memory because once we write any data in the ROM those are remaining unchanged in memory. 
          ROM performs the necessary Booting process to start the system and then transfers the control to the operating system.
Types of ROM
There are different types of ROM such as
PROM (Programmable Read Only Memory)
EPROM (Erasable Programmable ROM)
EEPROM (Electrically Erasable Programmable ROM)
13. Write about different types of software in details?
A. As you know computer cannot do anything without instructions from the user. In order to do any particular job you have to give a sequence of instructions to the computer. This set of instructions is called a computer program.
Software Types: 
Computer software is usually categorized into two broad categories.
Application Software
System software

Application Software:
            Application Software is a set of programs to carryout operations for a particular application. 
           Application software is useful for word processing, presentations, billing system, accounting, producing statistical report, medical analysis, small business processing, analysis of numerous data in research, weather forecasting, etc. 
             In future modules you will learn about MS WORD, Excel, Power Point, etc. All these are application software’s.
             Application software is broken in to two classes. They are: 
                      1.general-purpose software and 
                      2.application –specific software.
        
System Software: System software is a set of one or more programs designed to control the operation of computer system. 
             System software consists of programs that manage the hardware resources of a computer and performing tasks such as controlling, monitoring all operations required to do the internal and external functionalities of the computer.
     Remember that it is not possible to run application software without system software.
      DOS, UNIX and WINDOWS are some of the commonly used system software.
       These programs are categorized into three classes. They are:
1. operating system, 
2. system support, and 
3. system development.























UNIT - II
Overview of Operating System
1. Define an operating system.
A. The Operating System acts as an interface between the User, Application Programs, Hardware and the System Peripherals. The major objective of the OS is providing an environment in which the user can execute programs.
2. What is GUI?
A. A GUI (graphical user interface) is a system of interactive visual components for computer software. 
               GUI objects include icons, cursors, and buttons. 
          A GUI is considered to be more user-friendly than a text based command-line interface.
3. What is CUI?
A. command-line user interface, CUI is a way for users to interact with computer programs. 
            It works by allowing the user to issue commands as one or more lines of text (referred to as command lines) to a program. 
       Good examples CUIs are MS-DOS and the Windows Command Prompt.
4. Expand GUI, CUI, BIOS and MSDOS.
A. 	GUI: Graphical User Interface.
	CUI: Character User Interface.
	BIOS: Basic Input Output System.
	MSDOS: Microsoft Disk Operating System.
5. What are the main functions of DOS?
A. The major functions of DOS are to manage disk files, allocate system resources according to the requirement. DOS provides features necessary to control hardware devices such as Keyboard, Screen, Disk Devices, Printers, Modems and programs.
6. What is an internal command?
A. The internal commands reside in COMMAND.COM, which loads into memory when the computer system is turned on; these commands do not reside on disk. (?)is used to know the description of any command followed by the command. Ex: dir/?
7. What is an external command?
A. The external commands are files that do reside on disk and have an extension of .COM, .EXE, or .BAT.
8. What is an aero?
A. Aero
Sort over open windows with Aero Flip 3D.
Aero is an interface that creates your visual interactions with the desktop, fun and easy.
9. What is search bar?
A. Once you start typing in the Search bar of the Start Menu you will immediately see a list of relevant options collected by categories with highlighted keywords and text. This allows you to simply scan for the documents, music, pictures and email you are looking for.
10. What is gadget?
A. Windows holds mini-programs called gadgets, which suggest information at a glance and provide simple access to frequently used tools. 
             For instance, you can use gadgets to display a picture slide show, view continuously updated headlines, or look up contacts.
11. What is help and support in windows?
A.  Windows Help and Support is the predefined help system for Windows. It’s a place to get fast answers to common questions, suggestions for troubleshooting, and instructions for how to do works.
12. What is multitasking?
A.  Multitasking allows the user to perform more than one task at a time. For instance, work on a document file in MSWORD programs, while editing data automatically the beginning character convert into Capitalization and in the same time spell checking is done.
13. What is file system?
A. File system uses to perform files and folder in a systematic manner. The following operations are performed in file systems. They are creating, copying, moving, saving, opening, finding, renaming, deleting of files or folders.
14. What are four default libraries in library?
A. Pictures library. Use this library to organize and arrange your digitalpictures, whether you get them from your camera, scanner, or in e mail from other people.
Music library. Use this library to organize and arrange your digitalmusic, such as songs that you rip from an audio CD or that you download from the Internet.
Videos library. Use this library to organize and arrange your videos,such as clips from your digital camera or camcorder, or video files that you download from the Internet.
15. What is an icon?
A. Icons are small pictures that represent files, folders, programs, and other items. When you first start Windows, you’ll see at least one icon on your desktop: The Recycle Bin (more on that later). 
16. What is a folder?
A. A folder is a container you can use to store files and sub folders in. If you had thousands of paper files on your desk, it would be nearly difficult to find any particular file when you wanted it. That’s why people often store paper files in folders inside a filing cabinet. On your computer, folders work the same way.
17. What is desktop?
A.  The desktop is the main screen area that you see after you turn on your computer and log on to Windows. Like the top of an actual desk, it serves as a surface for your work. When you open programs or folders, they appear on the desktop. You can also put things on the desktop, such as files and folders, and arrange them however you want.
18. What is recycle bin?
A. When you delete a file or folder, it doesn’t actually get deleted right away— it goes to the Recycle Bin. That’s a good thing, because if you ever change your mind and decide you need a deleted file, you can get it back.
[image: A close-up of a glass of water
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19. What is control panel?
A. You can use Control Panel to change settings for Windows. These settings control nearly everything about how Windows looks and works, and they allow you to set up Windows so that it’s just right for you.
20. What is device manager?
A. Using Device Manager, you can view and update the device drivers installed on your computer, check to see if hardware is working properly, and modify hardware settings.
21. What is notification area in taskbar?
A. [image: Graphical user interface, application

Description automatically generated]The notification area, on the far right side of the taskbar, includes a clock and a group of icons. It looks like this.



Long Answer Questions
1.Write the main functions of an operating system?
A. The Operating System acts as an interface between the User, Application Programs, Hardware and the System Peripherals. The major objective of the OS is providing an environment in which the user can execute programs.
Program development
            The Operating System gives a mixture of facilities and services, for example editors and debuggers, to assist the programmer in creating programs.
Program execution:
        Execute a program the program must be loaded into main memory. Generally, a program is a collection of Instructions and data.
Access to I/O devices:
          The Operating System gives a uniform interface that hides these details so that programmers can access such devices using simple reads and writes.
Controlled access to files:
             In the multiple programming and multitasking environment, the OS may provide protection mechanisms to control access to file access.
System access:
          In shared or public systems, the OS controls the access of data within the files and the device is protected from unauthorized users and resolve the conflicts for resources.
Accounting:
          A good OS will collect usage statistics for various resources and monitor performance parameters like response time, waiting time and number of users within the system.
2.Write the Booting process in MSDOS.
A. DOS Boot-up Sequence: When we turn on the computer, if the system is MSDOS based, then the sequence of files to be executed as follows. The process is called Booting Process.
IO.SYS: A hidden file in the root directory of the primary drive. This file offers the basic I/O capabilities for the system, allowing it the ability to communicate with the different peripherals. 
MSDOS.SYS: Also, a hidden file in the root directory sometimes termed the kernel for DOS. When an application wants to access a device or peripheral, this file converts the request into actions that IO.SYS can perform.
CONFIG.SYS: A user-configurable text file that typically contains device drivers and system setup values.
COMMAND.COM: This is the Command Interpreter. It can take commands from the user, launch programs and transfer this Information to MSDOS.SYS.
AUTOEXEC.BAT: Another user-configurable text file that is used to set system variables and load TSRs.
3. Write about some internal commands.
A. 
	Common Micro Soft-DOS Commands

	Command
	Description
	Usage

	dir
	Lists all files in current directory
	Command: C:\>dir

	md
	Makes a new directory 

	Command:
md <directory name>

	cd
	Changes the current directory to the
one specified.
	Command:
C:\>cd <directory name>

	cd ..
	The command changes the directory to the parent directory of the current
directory.
	Command:
cd ..

	cd \
	The command changes to the root
directory of the current drive.
	Command: cd \

	move
	This command moves files or directories from the original directory specified to the new directory.
	Examples:
move
<source><destination>

	copy
	This command copies files from one location to another.
	Command:
copy
<source><destination>

	rename
	Changes the name under which files and/or directories are stored.
	Command:
rename	<original name><new name>

	rd
	Removes (deletes) a directory.


	Command:
rd<directory name>

	del
	Used to delete files. 

	Command:
del <file/directory name>

	CLS
	CLS is a command that allows a user to clear the complete contents of the screen and leave only a prompt
	Command:cls

	DATE
	Display the current date.

	Command: date

	TIME
	Allows the user to view and edit thecomputer’s time(system time).
	Command: time

	VER
	It displays the version of MSDOS
	Command: ver

	REN
	Used to rename files and directories from the original name to a newname
	Command: ren


4. Write about format and fdisk commands.
A. 
Format: Format is used to delete information off of a computer diskette or fixed drive.

The syntax of format command as follows.
FORMAT volume [/FS:file-system] [/V:label] [/Q] [/A:size] [/C] [/X] FORMAT volume [/V:label] [/Q] [/F:size]
FORMAT volume [/V:label] [/Q] [/T:tracks /N:sectors]
FORMAT volume [/V:label] [/Q] [/1] [/4] FORMAT volume [/Q] [/1] [/4] [/8]
Volume	      Specifies the drive letter (followed by a colon), mount point, or volume name.
/FS: filesystem	States the file system (FAT, FAT32, or NTFS).
/V: label	Specifies the volume label.
/Q	Does a quick format.
/C	Files created on the new volume will be compressed by default.
/X	Forces the volume to dismount first if needed. All opened handles to the volume would no longer be valid.

FDISK: Fdisk is used to delete and create partitions on the hard disk drive in earlier versions of MS-DOS and Windows.

Syntax
            FDISK [/STATUS] /X
/Status Displays partition information
/X Ignores extended disk-access support. Use this switch if you receive one of the below symptoms.
Unable to access a drive from DOS versions prior to 7 Disk access messages.
Stack overflow messages
High amounts of data corruption Extra drive letters
5. Write about aero options.
A. 
Aero: Sort over open windows with Aero Flip 3D.
Aero is an interface that creates your visual interactions with the desktop fun and easy. 
Aero Peek creates your open windows transparent. So you may see your desktop. It also permits you to peek at items in your taskbar for a thumbnail preview.
Aero Snap is a fast way to resize your windows to make them easier to read, compare and organize.
Aero Flip permits you to preview all your open windows from a central window or 3D view that you can flip through.
Aero Shake allows you to take your mouse and shake only the open window you need to focus on and the rest will disappear.
6. Write about gadgets.
A. Desktop Gadgets
          Windows holds mini programs called gadgets, which suggest information at a glance and provide simple access to frequently used tools.                                         For instance, you can use gadgets to display a picture slide show, view continuously updated headlines, or look up contacts.
Why use desktop gadgets:
Desktop gadgets can store information and tools readily available for you. For instance, you can display news headlines right next to your open programs.
Getting started with gadgets: To know how to use gadgets, let’s explore three gadgets: The Clock, Slide Show, and Feed Headlines.
How does the Clock work: When you right-click the Clock, you’ll see a list of tasks that what you can do with the gadget, including closing the Clock, keeping it on top of your open windows, and modifying the Clock’s options such as its name, time zone, time format and appearance?
Adding and removing gadgets: You can add any gadget by installed on your computer to the desktop. If you need, you can add multiple instances of a gadget.
     Right-click the gadget and then click Close Gadget.
Organizing gadgets: You can drag a gadget to a new position anyplace on the desktop.
7. Explain the help and support in windows.
A. Windows Help and Support is the predefined help system for Windows. It’s a place to get fast answers to common questions, suggestions for troubleshooting, and instructions for how to do works. 
[image: ]         To open Windows Help and Support, click the Start button then click                                    Help and Support.                     


Get the latest Help content: If you’re connected to the Internet, make sure Windows Help and Support is set to Online Help. 
         Online Help contains new Help topics and the newest versions of existing topics.
· On the toolbar in Windows Help and Support, click Options, and then choose settings.
· Under Search results, choose the Improve my search results by using online instruction check box, and then click OK. 
Search Help
The fastest way to get help is to type a word or two in the search box. For instance, to get information about wireless networking, type gadgets, and then press Enter. 
        A list of results seems, with the most useful results shown at the top. Click on the results to read the topic.
         You can also access Help by pressing F1. This function key opens Help in almost any program.
8. Write about file system.
A. File system uses to perform files and folder in a systematic manner. The following operations are performed in file systems. They are creating, copying, moving, saving, opening, finding, renaming, deleting of files or folders.
Working with files and folders
     A file is an item that consist of information—for example, text or images or music.
     files are represented with icons; this makes it easy to recognize a type of file by looking at its icon.
     A folder is a container you can use to store files and sub folders in.
     Folders can also store other folders. 
    A folder within a folder is usually called a subfolder. 
    You can create any number of subfolders, and each can hold any number of files and additional subfolders.
Viewing and arranging files and folders
     When you open a folder or library, you can change how the files look in the window. For example, you might prefer larger (or smaller) icons.
Arranging Files and Folders
       Each time you click the left side of the Views button, it changes the way your files and folders are displayed by cycling through five different views: 
Large Icons, 
List, 
a view called Details. 
a smaller icon view called Tiles, and 
a view called Content.
Finding Files
         The search box is located at the top of every window. To find a file, open the folder or library that makes the most sense as a starting point for your search, click the search box, and start typing.
Copying and moving files and folders
Copying
· Select the folder to be copied,
· Click on Copy
· Move the pointer(cursor) to the desired location to where you want
Click on Paste
Moving
· Select the folder to be copied,
· Click on Cut
· Move the pointer(cursor) to the desired location to where you want
· Click on Paste
9. Write about desktop components
A. The desktop is the main screen area that you see after you turn on your computer and log on to Windows. 
      You can also put things on the desktop, such as files and folders, and arrange them however you want.
      The desktop is sometimes defined more broadly to include the taskbar. The taskbar sits at the bottom of your screen.
Working with desktop icons:
          Icons are small pictures that represent files, folders, programs, and other items. When you first start Windows, you’ll s ee at least one icon on your desktop: The Recycle Bin.
Desktop Icons:
       You can choose which icons appear on the desktop—you can add or remove an icon at any time.
        If you want easy access from the desktop to your favorite files or programs, you can create shortcuts to them. 
      A shortcut is an icon that represents a link to an item, rather than the item itself. 
        When you double-click a shortcut, the item opens. 
        If you delete a shortcut, only the shortcut is removed, not the original item. 
        You can identify shortcuts by the arrow on their icon.
The Recycle Bin:
         When you delete a file or folder, it doesn’t actually get deleted right away— it goes to the Recycle Bin. 
         That’s a good thing, because if you ever change your mind and decide you need a deleted file, you can get it back.
10. Write about control panel
A. You can use Control Panel to change settings for Windows. These settings control nearly everything about how Windows looks and works, and they allow you to set up Windows so that it’s just right for you.
[image: ]
11. Write about device manager
A. Device Manager 
       Using Device Manager, you can view and update the device drivers installed on your computer, check to see if hardware is working properly, and modify hardware settings.
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If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
12. Write about taskbar?
A. The taskbar is the long horizontal bar at the bottom of your screen. Unlike the desktop, which can get obscured by open windows, the taskbar is almost always visible. It has three main sections:
1. The Start button[image: A picture containing application

Description automatically generated] , which opens the Start menu.
2. The middle section, which shows you which programs and files you have open and allows you to quickly switch between them.

3. The notification, which includes a clock and icons (small pictures) that communicate the status of certain programs and computer settings.

1.Start menu
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2.Middle section:
          You’re likely to use the middle section of the taskbar the most, so let’s look at it first.
         If you open more than one program or file at a time, you can quickly start piling up open windows on your desktop.



The Notification Area:
[image: ]    The notification area, on the far-right side of the taskbar, includes a clock and a group of icons. It looks like this.
Customize the Taskbar.
                There are many ways to customize the taskbar to suit your preferences. For example, you can move the entire taskbar to the left, right, or top edge of the screen.












   





UNIT - III
MS-Word
1. What is a Ribbon?
A. The top portion of the panel is called ribbon. The Ribbon contains all of the commands you'll need in order to perform common tasks. It contains multiple tabs, each with several groups.
2. What is office button?
A. Backstage view gives you various options for saving, opening, printing, and sharing your files. It's similar to the Microsoft Office button menu from Word 2007. 
          However, instead of just a menu it's a full-page view, which makes it easier to work with.
3. What is quick access toolbar?
A. The Quick Access toolbar, located above the Ribbon, lets you access common commands no matter which tab you're on. By default, it shows the Save, Undo, and Repeat commands. 
          You can add other commands to make it more convenient for you.
4. What are the tabs in the ribbon?
[bookmark: _Hlk72860274]A.      The Ribbon contains all of the commands you'll need in order to perform common tasks. It contains multiple tabs, each with several groups of commands, and you can add your own tabs that contain your favorite commands. The Tabs are:
		1. Home
		2. Insert
		3. Page Layout
		4. References
		5. Mailings
		6. Review
		7. View
5. What are the shortcuts for open and save a file? 
A. 
Opening a New Document:
the shortcut key creating a new empty document CTRL+N
Opening an Existing Document
Press CTRL+O on the keyboard
Saving a Document:
Press CTRL+S on the keyboard
6. What are the shortcuts for new and close a file?
A. 
     New Document: Simply use the shortcut key creating a new empty document CTRL+N on the keyboard. 
     Closing a Document:
To close a document: Click the Office Button ->Click Close   Alt+f4
7. What is the difference between copy and move?
A.    When you make copy (copy and paste) it is present at both places source and destination. 
        When you make a move (cut and paste) it is present only at the destination and no more in the source.
8. What is help system?
A. Help system provides facility to each feature in word you are using, and it is readily available by showing the icon.
9. What are the alignments in paragraph?
A. 
Align Left: the text is aligned with your left margin.
Center: The text is centered within your margins.
Align Right: Aligns text with the right margin.
Justify: Aligns text to both the left and right margins.
10. What are the indents in paragraph?
A. Indenting paragraphs allows you set text within a paragraph at different margins. There are several options for indenting:
First Line: Controls the left boundary for the first line of a 
                 paragraph.      
Hanging: Controls the left boundary of every line in a paragraph   
		except the first one.  
Left: Controls the left boundary for every line in a paragraph
Right: Controls the right boundary for every line in a paragraph
11. What is formatting a text?
A. Formatted text can emphasize important information and help organize your document. In Word, you have several options for adjusting the font of your text, including size, color, and inserting special symbols.
12. What is auto text?
		A. AutoText is a way to store and quickly insert text, graphics, fields, tables, bookmarks, and other items that you use frequently. 





13. What is autocorrect?
A. The AutoCorrect feature automatically corrects common typographical errors when you make them.
14. What is word count?
A. To check the word count in Word 2007 look at the bottom left corner of the screen. It will give you a total word count or if you have text highlighted it will tell you how many words are highlighted out of the total.
15. What is default dictionary?
A. The default custom dictionary is the dictionary to which Microsoft Word adds the word when you do this. Adds the word to the dictionary so it will never come up as an error. Make sure the word is spelled correctly before choosing this option.
16. What is thesaurus?
A. The Thesaurus allows you to view synonyms. To use the thesaurus:
Click the Review Tab of the Ribbon
Click the Thesaurus Button on the Proofing Group.

17. What is undo changes?
A. Undo is a function performed to reverse the action of an earlier action. For example, the undo function can undo deleted text in a word processor.
18. What are different types of tab alignments?
A. 
Left: Sets a left start position of text that will then run to the right as you type.
Center: Sets the position of the middle of the text. The text centers on this position as you type.
Right: Sets a right start position of text that will then run to the left as you type.
Decimal: Aligns numbers around a decimal point. Independent of the number of digits, the decimal point will be in the same position.
Bar: Inserts a vertical bar at the tab position. Not used for positioning text.
19. What are the options in page layout?
A. In this we can set margins, orientation (portrait or landscape), paper size, multiple columns, page breaks, page borders, page colors, water marks, etc.,
20. What is orientation?
A. Page orientation is the direction in which a document is displayed or printed. The two basic types of page orientation are portrait (vertical) and landscape (horizontal).
21. What is header and footer?
A. A header is text that is placed at the top of a page, while a footer is placed at the bottom, or foot, of a page. Typically, these areas are used for inserting document information, such as the name of the document, the chapter heading, page numbers, creation date and the like.
22. Draw a table with any data of your choice.
A. A Table is a collection of cells which are arranged in rows and columns. A Table can be used for various tasks mainly for presenting both textual data and numerical data.
 
	Stud .id
	Name
	English
	Telugu
	Hindi

	101
	Sirisha
	65
	59
	72

	102
	Manisha
	85
	75
	81

	103
	Hanisha
	76
	78
	80



23. What is clip art?
A. Clip art is a collection of pictures or images that can be imported into a document or another program.
24. What is smart art?
A. SmartArt is a way to turn ordinary text into something more visually appealing. It helps draw attention to important information or make information easier to interpret and understand.
25. What is water mark?
A. A watermark is a faded image or text, that sits across the contents of a document. Watermarks can be used to indicate what stage the document is in, draft, confidential, final copy etc.
26. What is mail merge?
A. Merging of document and non-document is called mail-merge. Mail Merge is a very useful tool that allows user to produce multiple letters, envelopes, labels, name tags, and more using information stored in a list, database, or spread sheet.




Long Answer Type Questions
1.Write the stepwise procedure to create, edit and save a document in word?
A. 
Editing a Document:
There are several ways to create a new document, opening an existing document, and saving documents in Word
Create a Document:
Click the Microsoft Office Button[image: A picture containing icon

Description automatically generated] and Click New or Simply use the shortcut key creating a new empty document CTRL+N (Depress the CTRL key while pressing the “N”) on the keyboard.
Opening an Existing Document:
     Click the Microsoft Office Button [image: A picture containing icon

Description automatically generated] and Click Open, or Press CTRL+O (Depress the CTRL key while pressing the “O”) on the keyboard, or If you have recently used the document you can click the Microsoft Office
Button[image: A picture containing text

Description automatically generated] and click the name of the document in the Recent Documents section of the window Insert picture of recent docs.
Saving a Document:
· Click the Microsoft Office Button [image: A picture containing icon

Description automatically generated]and Click Save or Save As, or
· Press CTRL+S (hold the CTRL key and press “s”) on the keyboard, or

· Click the File icon on the Quick Access Toolbar

Closing a Document:
To close a document:

Click the Office Button ->Click Close.
2. Write about document views.
A. Document Views:

There are many ways to view a document in Word.

Print Layout: This is a view of the document as it would appear when printed. It includes all tables, text, graphics, and images.
Full Screen Reading: This is a full view length view of a document. Good or viewing two pages at a time.
Web Layout: This is a view of the document as it would appear in a web browser.
Outline: This is an outline form of the document in the form of bullets.
Draft: This view does not display pictures or layouts, just text.
        To view a document in different forms, click the document views shortcuts at the bottom of the screen [image: A picture containing text, window

Description automatically generated]or Click the View Tab on the Ribbon.
3. Write about move and copy.
A. Move and Copy Text:

In order to move or copy the text from one place to another place first we have to select the text which we want to copy or move
Selecting Text

To change any attributes of text it must be highlighted first. Select the text by dragging the mouse over the desired text while keeping the left mouse button depressed, or hold down the SHIFT key on the keyboard while using the arrow buttons to highlight the text. 
Method to Copy and Paste Text
To move text:
Cut and paste method
1. Select the text.
2. On the Clipboard group on the Home tab, click the Cut button. or
3. Right click and choose Cut.
4. Place the insertion point where you want the text to be inserted.
5. On the Clipboard group on the Home tab, click the Paste button.or
6. Right click and choose Paste.
Drag-and-drop editing method
1. Select the text.
2. Drag the selected text, placing the mouse pointer’s insertion point at the desired location.
To copy text:
Copy and paste method
1. Select the text.
2. On the Clipboard group on the Home tab, click the Copy button. or
3. Right click and choose Copy.
4. Place the insertion point where you want the text to be inserted.
5. On the Clipboard group on the Home tab, click the Paste button. or
6. Right click and choose Paste.
Drag-and-drop editing method
1. Select the text.
2. Press and hold the Ctrl key as you drag the selected text, placing the mouse pointer’s grey line at the desired location.
4. Write about formatting the paragraph.
A. 
Formatting Paragraph:
        Formatting paragraphs allows you to change the look of the overall document.
         You can access many of the tools of paragraph formatting by clicking the Page Layout Tab of the Ribbon or the Paragraph Group on the Home Tab of the Ribbon.
          The paragraph alignment allows you to set how you want text to appear. To change the alignment:
          Click the Home Tab
          Choose the appropriate button for alignment on the Paragraph Group.
Align Left: the text is aligned with your left margin.
Center: The text is centered within your margins.
Align Right: Aligns text with the right margin.
Justify: Aligns text to both the left and right margins.
Indent paragraphs:
      Indenting paragraphs allows you set text within a paragraph at different margins. There are several options for indenting:
First Line: Controls the left boundary for the first line of a paragraph.
Hanging: Controls the left boundary of every line in a paragraph except the first one
Left: Controls the left boundary for every line in a paragraph
Right: Controls the right boundary for every line in a paragraph
Add Borders and Shading:
        You can add borders and shading to paragraphs and entire pages. To create a border around a paragraph or paragraphs:
Select the area of text where you want the border or shading.
Click the Borders Button on the Paragraph Group on the Home Tab Choose the Border and Shading.


Change Spacing Between Paragraphs and Lines:
       You can change the space between lines and paragraphs by doing the following: 
                                 Select the paragraph or paragraphs you wish to change.
           On the Home Tab, Click the Paragraph Dialog Box Click the Indents and Spacing Tab
           In the Spacing section, adjust your spacing accordingly.
5. Write about find and replace?
A. Find and Replace Text :
Find and Replace Text
To find a particular word or phrase in a document:
           Click Find on the Editing Group on the Ribbon
           To find and replace a word or phrase in the document, click Replace on the Editing Group of the Ribbon.
Undo Changes:
     To undo changes:
     Click the Undo Button on the Quick Access Toolbar
[image: Graphical user interface, application
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Find Text:
1. Click on Home button and select Find button placed on the top left end.
2. Short cut key for find is CTRL+F.
3. Then enter the word you want to find.
Replace Text:
1. After finding the text you want to replace
2. Press CTRL+H shortcut key
3. Then select all option to replace text.
6. Write about spell checker?
A. Spell Checking:
Introduction:
           Are you worried about making mistakes when you type? Don't be. Word provides you with several proofing features that will help you produce professional, error-free documents.
Checking spelling and grammar:
           To make your document appear professional, you'll want to make sure it is free from spelling and grammar errors.
To run a spelling and grammar check:
        1.Go to the Review tab.
        2.Click on the Spelling & Grammar command.
        3.The Spelling and Grammar dialog box will open. For each error in your document, Word will try to offer one or more suggestions. You can select a suggestion and click Change to correct the error.
         4. If no suggestions are given, you can manually type the correct spelling.
Ignoring "errors"
          The spelling and grammar check is not always correct. Particularly with grammar, there are many errors Word will not notice.
For spelling "errors"
Ignore Once: This will skip the word without changing it.
Ignore All: This will skip the word without changing it, and it will also skip all other instances of this word in the document.
Add to Dictionary: This adds the word to the dictionary so it will never come up as an error. Make sure the word is spelled correctly before choosing this option.
For grammar "errors"
Ignore Once: This will skip the "error" without changing it.
Ignore Rule: This will skip this "error" and all other instances that relate to this grammar rule.
Next Sentence: This skips the sentence without changing it and leaves it marked as an error. This means it will still show up if you do another spelling and grammar check later.
To use the spelling check feature:
1. Right-click the underlined word. A menu will appear.
2. Click the correct spelling of the word from the listed suggestions.
3. The corrected word will appear in the document.
You can choose to ignore an underlined word, add it to the dictionary, or go to the Spelling dialog box for more options.
To use the grammar check feature:
1. Right-click the underlined word or phrase. A menu will appear.
2. Click the correct phrase from the listed suggestions.
3. The corrected phrase will appear in the document.
You can also choose to Ignore an underlined phrase, go to the Grammar dialog box, or click About This Sentence for information on the grammar rule.
7. Write about tabs.
A. Tabs
     Using tabs gives you more control over the placement of text. 
     By default,	on pressing a tab key the insertion point will be 0.5” towards right. 
    On continuing pressing the points will be 0.5”,1.0”,1.5” and so on. 
    By adding tab stops to the Ruler, you can change the size of the tabs, and one can apply more than one tab stop to a single line in Word.
     The tab selector is located to the left of horizontal ruler. Hovering the mouse o selector displays the name of the active tab stop.e
v

Types of tab stops:
[image: ]Left Tab	left-aligns the text at the tab stop.
Center Tab [image: ] centers the text around the tab stop.
Right Tab [image: ] right-aligns the text at the tab stop.
Decimal Tab [image: ] aligns decimal numbers using the decimal point.
Bar Tab [image: ] draws a vertical line on the document.
First Line Indent [image: ] inserts the indent marker on the Ruler and indents the first line of text in a paragraph.
Hanging Indent [image: ] inserts the hanging indent marker and indents all lines other than the first line.
Tab stop position: Type the position on the ruler where you want to create a new tab stop or select an existing tab stop from the list to modify its properties.
Default tab stops: Specifies amount of spacing that is applied each time you press the TAB key.
Tab stops to be cleared: Displays tab stops that have been marked for deletion from the Tab stop position list. Cleared tabs are deleted from the list when you click OK.
Alignment:
Left: Sets a left start position of text that will then run to the right as you type.
Center: Sets the position of the middle of the text. The text centers on this position as you type.
Right: Sets a right start position of text that will then run to the left as you type.
Decimal: Aligns numbers around a decimal point. Independent of the number of digits, the decimal point will be in the same position.
8. Explain the options in detail in page layout?
A. Enhancing a Document (Page Layout):
       Before printing a document, we must set the pages by using page setup. In this we can set margins, orientation (portrait or landscape), paper size, multiple columns, page breaks, page borders, page colors, water marks, etc.,

Modify Page Margins and Orientations:
The page margins can be modified through the following steps:
1. Click the Page Layout Tab on the Ribbon
2. On the Page Setup Group, Click Margins
3. Click a Default Margin, or
4. Click Custom Margins and complete the dialog box.
To change the Orientation, Size of the Page, or Columns:
1. Click the Page Layout Tab on the Ribbon
2. On the Page Setup Group, Click the Orientation, Size, or Columns drop down menus.
3. Click the appropriate choice.
Apply a Page Border and Color
1. Click the Page Layout Tab on the Ribbon
2. On the Page Background Group, click the Page Colors or Page Borders drop down menus.
Insert Common Header and Footer Information:
      To insert Header and Footer information such as page numbers, date, or title, first, decide if you want the information in the header (at the top of the page) or in the Footer (at the bottom of the page), then:
1. Click the Insert Tab on the Ribbon
2. Click Header or Footer
3. Choose a style.
Create a Page Break:
To insert a page break:
1. Click the Page Layout Tab on the Ribbon
2. On the Page Setup Group, click the Breaks Drop Down Menu
9. Write about tables?
A. Tables
     A Table is a collection of cells which are arranged in rows and columns. A Table can be used for various tasks mainly for presenting both textual data and numerical data.
To Create a Table:
1. Place the cursor on the page where you want the new table.
2. Click the Insert Tab of the Ribbon
3. Click the Table Button on the Tables Group. You can create a table one of four ways:
4. Highlight the number of row and columns.
5. Click Insert Table and enter the number of rows and columns.
6. Click the Draw Table, create your table by clicking and entering the rows and columns.
7. Click Quick Tables and choose a table
Enter Data in a Table:
Place the cursor in the cell where you wish to enter the information. Begin typing.
Modify the Table Structure and Format a Table.





To format a table, click the table and then click the Layout Tab on the Ribbon. This Layout tab allows you to:
· View Gridlines and Properties (from the Table Group)
· Insert Rows and Columns (from the Rows & Columns Group)
· Delete the Table, Rows and/or Columns (from the Rows & Columns Group)
· Merge or Split Cells (from the Merge Group)
· Increase and Decrease cell size (Cell Size Group)
· Align text within the cells and change text directions (Alignment Group).
To ADD a Row or a Column for an existing table:
Inserting Row:
1. To add a Row place the insertion point in a row below the location where you want to add a row.
2. Right-click the mouse. A menu appears.
3. Select Insert Rows Above/Below.
Inserting column:3

1. Place the insertion point in a column adjacent to the location where you want the new column to appear.
2. Right-click the mouse. A menu appears.
3. [image: ]Select Insert	Insert Columns to the Left or Insert Columns to the Right
4. new column appears.
10. Write about graphics?
A. Word provides a set of drawing tools that you can use to create simple graphics. The pictures, clip art, shapes, smart art, equations etc are available in insert tab.
Symbols and Special Characters:
Special characters are punctuation, spacing, or typographical characters that are not generally available on the standard keyboard. To insert symbols and special characters:
1. Place your cursor in the document where you want the symbol.
2. Click on the Insert Tab on the Ribbon
3. Click on the Symbol button on the Symbols Group.
4. Select the appropriate symbol.
Equations:
Word 2007 also allows you to insert mathematical equations. To access the mathematical equations tool:
1. Place your cursor in the document where you want the symbol1.
2. Click the Insert Tab on the Ribbon
3. Click the Equation Button on the Symbols Group
4. Choose the appropriate equation and structure or click Insert New Equation
5. To edit the equation, click the equation and the Design Tab will be available in the Ribbon.
Illustrations, Pictures, and Smart Art:
Word allows you to insert illustrations and pictures into a document.
To insert illustrations:
1. Place your cursor in the document where you want the illustration/picture.
2. Click the Insert Tab on the Ribbon
3. Click the Clip Art Button
4. The dialog box will open on the screen, and you can search for clip art.
Choose the illustration you wish to include.
To insert a Picture:
1. Place your cursor in the document where you want the illustration/	picture.
2. Click the Insert Tab on the Ribbon
3. Click the Picture Button
4. Browse to the picture you wish to include.
5. Click the Picture.
6. Click Insert
To insert SmartArt:
Place your cursor in the document where you want the illustration/	picture
· Click the Insert Tab on the Ribbon
· Click the SmartArt button
· Click the SmartArt you wish to include in your document.
· Click the arrow on the left side of the graphic to insert text or type the text in the graphic.
11. Write about mail merge.
A.      Mail Merge is an especially useful tool that allows user to produce multiple letters, envelopes, labels, name tags, and more using information stored in a list, database, or spread sheet. 
           There are six main steps to complete a merge. The appeared Mail Merge pane and will guide you. The following example explains how to create a form letter and merge the letter with a recipient list.
Step 1:
          Choose the type of document you want to create. Let us select Letters in our example. Then click Next: Starting document to move to Step 2.
Step 2:
          Select Use the current document and then click Next: Select recipients to move to Step 3.
Step 3:
          Now you will need an address list so that Word can automatically place each address into the document. The list can be in an existing file, such as an Excel workbook, or you can type a new address list from within the Mail Merge Wizard.
          If you do not have an existing address list, you can click the Type a new list button and click Create. You can then type your address list.
Step 4:
         Now you are ready to write your letter. When it's printed, each copy of the letter will basically be the same; only the recipient data (such as the name and address) will be different. You'll need to add placeholders for the recipient data, so Mail Merge knows exactly where to add the data.
To insert recipient data:
1. Place the insertion point in the document where you want the information to appear.
2. Choose	one	of	the	four placeholder options: Address	block, Greeting line, electronic postage, or More items.
3. Based on your selection, a dialog box may appear with various options. Select the desired options and click OK.
Step 5:
1. Preview the letters to make sure the information from the recipient list appears correctly in the letter. Also left and right scroll arrows can be used to view each document.
2. Click Next: Complete the merge to move to Step 6.
Step 6:
1. Click Print... to print the letters.
2. A dialog box will appear. Click All, then click OK.
3. The Print dialog box will appear. Adjust the print settings if needed, then click OK. The letters will be printed.



12. Write about bullets and numbering?
A. Bulleted and Numbered Lists
    Bulleted lists have bullet points, numbered lists have numbers, and summarize lists combine numbers and letters depending on the organization of the list.
To add a list to existing text
1. Select the text you wish to make a list
2. From the Paragraph Group on the Home Tab, Click the Bulleted or Numbered Lists button.
To create a new list:
1. put your cursor where you wish for the list in the document.
2. Click the Bulleted or Numbered Lists button
3. Begin typing.
Nested Lists:
A nested list is list with a few levels of indented text. To create a nested List:
1. Create your list following the directions above.
2. Click the Increase or Decrease Indent button
Formatting Lists
The bullet image and numbering format can be altered by using the Bullets or Numbering dialog box.
1. Select the whole list to change all the bullets or numbers, or place the cursor on one line within the list to modify a single bullet
2. Right click.
3. Click the arrow next to the bulleted or numbered list and decide a bullet or numbering style.
13. Write about word art?
A. Word Art
        Word art is used to show the textual data with diverse styles and various sizes. Sometimes we must design textual data in a mixture of styles. Then we must prefer word art On the Insert tab, in the Text group, click WordArt, and then choose the WordArt style that you want.
Type your text in the text box Word.
Do one or more of the following:
1. To modify the text, select it, and then make the changes that you want.
2. To modify the font, see Change the font, font size, or font color,.3
3.  or Apply bold, italic, or highlight formatting to text.
4. To add an effect to WordArt, see Add or delete a fill, summarize, or effect for text or WordArt.
5. To rotate the WordArt, observe Rotate or flip a picture, shape, or WordArt in Word 2007.
6. To resize the WordArt, observe Change the size of a picture, shape, text box, or Word Art.
7. To align the WordArt, observe Align or arrange a picture, shape, text box, or WordArt.
8. To move the WordArt, notice to Move a picture, shape, text box, or WordArt.

UNIT - IV
MS-Excel
1. What is a spread sheet?
A. A spread sheet is an electronic document that stores different types of data. There are vertical columns and horizontal rows. The intersecting part of rows and column is called cell. So spread sheet is a collection cell.
2. What is a Ribbon?
A.      The ribbon or Menu Bar is the panel at the top portion of the document. It consists of several menus in form separate tabs. 
       It has seven tabs: Home, Insert, Page Layouts, Formulas, Data, Review, and View. Each tab is divided into groups or sub menus.
3. What is mini toolbar?
A.        A new feature in Office 2007 is the Mini Toolbar. This is a floating toolbar that is displayed when you select text or right-click text. 
         It displays common formatting tools, such as Bold, Italics, Fonts, Font Size and Font Color.
4. How many rows and columns in excel 2007?
A. Since Excel 2007 the number of rows and columns is much bigger than before. This time there are 1,048,576 rows and 16,384 columns (XFD). Therefore, the last cell is XFD or1048576.
5. What is the difference between workbook and worksheet?
A. A worksheet is nothing but a single spreadsheet page, but a workbook is a collection of all the worksheets belongs to a single file.
6.How the columns and rows are represented in a work sheet?
A. In the work sheet the rows are specified by 1, 2, 3, 4…and the columns are specified by A, B, C, D, The cell address denoted by means of column number and row number. For example, a cell B3 means row number 3 and column number B.
7. What is a formula?
A. A formula is an equation that performs a calculation. Like a calculator, Excel can execute formulas that financial, text, auto sum, logical, date & Time...Etc.
8. What is undo and redo?
A.         if you have committed any action accidentally in your document then do not worry there is an option called UNDO, which will remove the last action which you had performed in your document.
         And similarly, if you had deleted the content or any other accidentally by undo then we use REDO option which will give you the last deleted data in your document.
9. What is auto fill?
A.      The Auto Fill feature fills cell with data or series of data in a worksheet into a selected range of cells. 
          If you want the same data in all the cells, then only you have to enter that data in one cell and you have to first select that cell and drag to the no. of cells in which you want that data.



10. What is find and replace?
A. For example, assume that you are typing a document and accidentally you have entered the name of a person as Murali but his name in Krishna, then simply you can use this feature Find and Replace.
11. What is Go to command?
A. The Go To command will takes you to a specific cell either by cell reference (the Column Number and the Row Number) or by cell name.
12. What is spell check?
A. This option is used to Check the Spelling within the Current working worksheet to check the spelling:
On the Review tab click the Spelling button.
13. What is split screen?
A. Split the window into multiple resizable panes containing views of your worksheet. By this feature you can view distant parts of your worksheet at once.
14. What is the difference between copy and move?
A. Excel allows you to copy a cell or collection of cells to any location either within the work sheet or to another work sheet. In the same way you can move a cell or collection of cells to any part of any work sheet. For copy and paste you can use commands or buttons.
15. What are the six options in format cells?
A. There are several tabs on this dialog box that allow you to change properties of the cell or cells.
Number: Allows for the display of different types of numbers and decimal places
Alignment: Allows for the horizontal and vertical alignment(arrangement) of text, wrap text, shrink text, merged cells and the direction of the text.
Font: Allows for control of font, font style, size, color, and additional features
Border: Border styles and colors
Fill: Cell fill colors and styles
16. What are the alignments?
A. There are several options for alignment of cell contents:
Top Align: Aligns text to the top of the cell
Middle Align: Aligns text between the top and bottom of the cell
Bottom Align: Aligns text to the bottomof the cell
Align Text Left: Aligns text to the left of the cell
Center: Centers the text from left to right in the cell
Align Text Right: Aligns text to the right of the cell
Decrease Indent: Decreases the indent between the left border and thetext
Increase Indent: Increase the indent between the left border and the text
Orientation: Rotate the text diagonally or vertically
17. What are merge cells?
A. To merge the cells firstly you have to select the cells to merge and click the Merge &Center button on the Alignment group of the home tab. The four choices for merging cells are:
Merge & Center: Combines the cells and centers the contents in the   new, larger cell.
Merge Across: Combines the cells across columns without centering data.
Merge Cells: Combines the cells in a range without centering.
Unmerge Cells: Splits the cell that has been merged.

18. What are the shortcut keys for bold, italic and underline?
A. 
	Bold
	Ctrl+B 

	Italics
	Ctrl+I 

	Underline
	Ctrl+U 


19. What is the importance of saving a worksheet?
A. The work sheet that you have worked so far has been stored in RAM (Random Access Memory) of your system. The RAM is volatile. i.e., it loses its contents, if the power is switched off to system. Therefore, you must save the work sheet for future reference.
20. What is the difference between save and save as?
A. Save is used to store the file with same name but save as is used to store with another name and also can be stored in another location.
21. What is the importance of charts?
A. A chart is a tool you can use in Excel to communicate data graphically. charts convey the message clearly and quickly without any effort, they play important role in the business world.
22. What are the different types of charts?
A. types of charts including Column, Line, Pie, Bar, Area, Scatter and more.
23. What is a macro?
A. The macro is a useful feature of excel that helps to automatic keystrokes (commands) required to execute any command or task. Macros can be used for numeric tasks such as:
1. Formatting of ranges
2. Printing a worksheet range
3. Creating charts
  4. Accepting data from the user and putting that in a database
24. What is a table?
A. A table is made up of rows and columns. Tables are often used to organize and present information, but they have a variety of other uses as well. You can use tables to align numbers in columns, and then sort and perform calculations on them.
25. What is a PivotTable?
A. PivotTables are used to looking at data in several dimensions, For instance, sales by region, sales by sales representatives, sales by product category, and sales by month, etc.






Long Answer Type Questions
1. Write the 7 tabs in excel and write the groups in each tab.
[bookmark: _Hlk73550860]A.       The ribbon or Menu Bar is the panel at the top portion of the document. It consist of several menus in form separate tabs. 
        It has seven tabs: Home, Insert, Page Layouts, Formulas, Data, Review, and View. Each tab is divided into groups or sub menus.
         Commonly utilized features are displayed on the Menu Bar. To view extra features within each group and to change the default setting, click the arrow at the bottom right corner of each group.
Home: Clipboard, Fonts, Alignment, Number, Styles, Cells, Editing
Insert: Tables, Illustrations, Charts, Links, Text
Page Layouts: Themes, Page Setup, Scale to Fit, Sheet Options, Arrange
Formulas: Function Library, Defined Names, Formula Auditing, Calculation
Data: Get External Data, Connections, Sort & Filter, Data Tools, Outline
Review: Proofing, Comments, Changes
View: Workbook Views, Show/Hide, Zoom, Window, Macros
2. Write and explain any six functions?
A. Overview of Function Library: The function library is a large group of functions on the Formula Tab of the Ribbon. These functions include.
AutoSum: Easily calculates the sum of a range.
Recently Used: All recently used functions.
Financial: Accrued interest, cash flow return rates and additional financial functions
Logical: And, If, True, False, etc.
Text: Text based functions
Date & Time: Functions calculated on date and time
Math & Trig: Mathematical Functions
1.Click the Insert Function button
Use the Insert Function button under the Formulas tab to select a function from Excel’s menu list:
=COUNT (B4:B13) Counts the numbers in a range (ignores blank/empty cells).
=COUNTA (B3:B13) Counts all characters in a range (also ignores blank/empty cells).
2. Select a function from a group (Formula’s tab)
Narrow your search a bit and choose a formula subset for Financial, Logical, or Date/Time, month and hour, for example.
        =TODAY () Inserts today’s date.
3. The Recently Used button
       Select the Recently Used button to show functions you've used recently. It is a welcome timesaver, especially when working with an extra spreadsheet.
         =AVERAGE (B4:B13) adds the list, divides by the number of values, then provides the average.
4. Auto functions under the AutoSum button
        Auto functions are my editor's personal favorite because they're so fast. Select a cell range and a function, and your result appears with no muss or fuss. Here are a few examples:
        =MAX (B4:B13) returns the highest value in the list.
     =MIN (B4:B13) returns the lowest value in the list.
[image: A picture containing text, white

Description automatically generated]3. Write and explain any five mathematical functions.
A. 
1.POWER: Used to find the results of a number raised to a power and returns the result
    Syntax: POWER (number, power)
Example:
         POWER (C2, E2) gives result 25 because (42 = 16)
2.FACT: Used to calculate the factorial of a number.
Syntax:     FACT (number)
Example
     FACT(C2) gives 24 because B2 in Figure 4.23 contains 4 i.e. (1 x 2 x 3 x 4 = 24). 
3.SQRT: Finds the square root of a value in the cell.
Syntax:  SQRT (number)
Example
                SQRT(C2) gives 2 because square root of 4 is 2.
4.SUM: The SUM function adds all the numbers that you specify as arguments.
Syntax
[bookmark: _Hlk73810006]            SUM (number1, [number2], [number3], [number4] …)
Example:
            SUM (A2:E2) Gives the result 20 because (3 + 5 +4 + 6 + 2 = 20)
5.SUMIF: You use the SUMIF function to sum the values in a range that meet criteria that you specify. It will check the condition if the condition is true then only it will return the value.
SYNTAX:
           SUMIF (RANGE, CRITERIA)
Example:
           SUMIF (A2:E2,”>4”) Gives result 11 because (5 + 6).
6.MOD: Returns the remainder as the result after number is divided by divisor. The sign of the result is same as the sign as divisor.
Syntax: 
           MOD (number, divisor)
Ex1: MOD (B2, A2) gives result 2 because remainder is 2 when 5 is divided by 3
[image: A picture containing text, white

Description automatically generated]4. Write and explain any five statistical functions?
A. 
1.Average: Returns average (arithmetic mean) of the arguments ..The AVERAGE function syntax has the following arguments
Syntax: average (number1, number2) 
Example:
          Average (a2: e2) gives result 4 because (3+5+4+6+2)/5 = 4
2.Count: The COUNT function is used to count the number of cells that contain numbers and counts numbers within the list of arguments. 
     Use the COUNT function to get the number of entries in a number field that is in a range or array of numbers.
Syntax:
           Count (value1, [value2] ...)
Example:
          Count (a4: e4) gives result 3 because (12,8,4 is 3 values)
3.Count A: The COUNTA function counts the number of cells that are not empty in a range.
Syntax:
              COUNTA (value1, [value2], ...)
Ex: 
               countA (A4:E4) gives the result 4 because the range contains 4 values.
4.Count Blank: Returns the count of no. of empty cells present in a specific range.
Syntax:
           COUNTBLANK (range)
Range is the range from which you want to count the blank cells.
Example:
             CountBlank (A4:E4) gives result 1 because the range contains one blank.
5.Count If: The COUNTIF function counts the number of cells within a range that meet a single condition that you specify.
Syntax:
            COUNTIF (range, criteria)
Ex:
             Countif (A4:E4,”>10") gives result 1 because the range contains only one value that is greater than 10.
6.MAX: Returns the maximum value in the range.
Syntax:
            MAX (number1, number2)
Ex: max (A2:E2) gives result 6 because 6 is the maximum value in that range.
7.MIN: Returns the minimum value in the range.
Syntax:
               MIN (number1, number2,)
Ex: max (A2:E2) gives result 2 because 6 is the minimum value in that range





5.Explain copy and move the range of cells with an example?
A. Excel allows you to perform some operations on the cells like moving a cell, copying a cell, and paste cell and we can perform cut and paste operation as well as copy and paste operation on the data present in the cells.
Select Data:
To select a cell or data: Click the1cell.
To select multiple cells just click and drag the cursor.
copying multiple cells Select a Row or Column
To select a row or column click on the row or column header.
Copy and Paste:
To copy and paste data:
Select the cell(s) that you wish to copy.
On the Clipboard group of the home tab, click Copy.
Copy and Paste Buttons
Select the cell(s) that you wish to copy.
On the Clipboard group of the home tab, click Paste.
Cut and Paste:
To cut and paste data:
Select the cell(s) that you wish to cut.
On the Clipboard group of the home tab, click Cut.
Cut Buttons
Select the cell(s) that you wish to paste.
On the Clipboard group of the home tab, click Paste
6. Write the procedure to open, save and print a worksheet.
A. Print a worksheet or workbook:
      You can print entire or partial worksheets or workbooks, one at a time, or several at once.
      You can also print a workbook to a file instead of to a printer. This is useful when you need to print the workbook on a different type of printer from the one that you originally used to print it. 
Print a workbook to a file:
       1.Click Microsoft Office Button [image: ], and then click Print. Keyboard shortcut You can also press CTRL+P.
      2.In the Name box, select the printer on which you want to print the file. 
      3.Select the Print to file check box, and then click OK.
      4.In the Print to File dialog box, under Output File Name, type a name for the file that you want to print.
7. Write about charts?
A.            A chart is a tool you can use in Excel to communicate data graphically. Because charts convey the message clearly and quickly without any effort, they play important role in the business world.
           Excel offers many types of charts including Column, Line, Pie, Bar, Area, Scatter and more. To view the charts available, select the Insert Tab on the Ribbon.




Create a Chart:
To create a chart:
1.First you must select the cells that contain the data you want to use in the       chart.
2.Click the Insert tab on the Ribbon.
3.Click the type of Chart you want to create.
Modify a Chart.
Once you have created a chart you can do several things to modify the chart. 
To move the chart:
1.Click the Chart and Drag it another location on the same worksheet, or
2.Click the Move Chart button on the Design tab
3.Choose the desired location (either a new sheet or a current sheet in the workbook)
To change the data included in the chart:
1.Click the Chart.
2.Click the Select Data button on the Design tab
Selecting a Data Source
To reverse data are displayed in the rows and columns:
1.Click the Chart.
2.Click the Switch Row/Column button on the Design tab.
Reversing the data chart:
To modify the labels and titles:
1.Click the Chart.
2.On the Layout tab, click the Chart Title or the Data Labels button
3.Change the Title and click Enter
Copy a Chart to Word
1.Select the chart.
2.Click Copy on the Home tab
3.Go to the Word document where you want the chart located Select
4.Paste on the Home tab
8. Write about macros.
A.     The macro is a useful feature of excel that helps to automatic keystrokes (commands) required to execute any command or task. Macros can be used for numeric tasks such as:
Formatting of ranges
Printing a worksheet range
Creating charts
Accepting data from the user and putting that in a database
           Macros are advanced features in Excel that can speed up editing or formatting operations you may perform. They record sequences of menu selections that you choose so that a series of actions can be completed in one step.
Recording a Macro
To record a Macro, we must do the following:
1.Click the View tab on the Ribbon.
2.Click Macros
3.Select Record Macro
4.Enter a name (without spaces)
5.Enter a Shortcut Key
6.Enter a Description.
· Perform the Macro.
· Click Macros
· Select Stop Recording
Running a Macro:
To run a Macro from your Keyboard shortcut, simply press the keys that you have programmed to run the Macro. Or you can view all macros and run by:
1.Click Macros
2.Click View Macros
3.Choose the Macro and click Run
9. Write about tables in excel?
A. A table is made up of rows and columns. Tables are often used to organize and present information, but they have a variety of other uses as well. You can use tables to align numbers in columns, and then sort and perform calculations on them.
Create a Table:
There are two ways to create a table. You can insert a table in the default table style, or you can format your data as a table in a style that you select.
Insert a table:
     On a worksheet, choose the range of cells that you need to include in the table. The cells can be empty or can contain data.
     On the Insert tab, in the Tables group, click Table.
Keyboard shortcut you can also press CTRL+L or CTRL+T.
       If the choose range contains data that you need to display as table headers, choose the My table has headers check box.
Format data as a table:
      1.On the worksheet, choose a range of empty cells or cells that hold the data that you need to quickly format as a table.
      2.On the Home tab, in the Styles group, click Format as Table.
When you use Format as Table, Office Excel automatically inserts a table.
1. Under Light, Medium, or Dark, click the table style that you want to use.
Convert a table to a range of data:
1.Click anywhere in the table.
       Tip: This displays the Table Tools, adding the Design tab.
2.On the Design tab, in the Tools group, click Convert to Range.
Delete a table:
1.On a worksheet, select a table.
2.Press DELETE
10. Write about PivotTables in excel?
A.      PivotTables are used to looking at data in several dimensions, For instance, sales by region, sales by sales representatives, sales by product category, and sales by month, etc.
        A PivotTable report is an interactive way to quickly summarize large amounts of data. Use a PivotTable report to analyses numerical data in detail and to answer unanticipated questions about your data.
 A PivotTable report is especially designed for:
· Querying large amounts of data in many user-friendly ways.
· Subtotaling and aggregating numeric data, summarizing data by categories and subcategories, and creating custom calculations and formulas.
· Filtering, sorting, grouping, and conditionally formatting the most useful and interesting subset of data to enable you to focus on the information that you want.
· Presenting concise, attractive, and annotated online or printed reports.
Ways to work with a PivotTable report:
Explore the data by doing the following:
· Expand and collapse data, and show the underlying details that pertain to the     values.
· Sort, filter, and group fields and items.
· Modify summary functions, and add custom calculations and formulas.
Modify the form layout and field arrangement by doing the following:
· Modify the PivotTable report form: compact, outline, or tabular.
· Add, rearrange, and remove fields.
· Modify the order of fields or items.
Modify the layout of columns, rows, and subtotals by doing the following:
· Turn column and row field headers on or off, or display or hide blank lines.
· Display subtotals above or below their rows.
· Adjust column widths on refresh.
· Move a column field to the row area or a row field to the column area.
· Merge or unmerge cells for outer row and column items.
Modify the display of blanks and errors by doing the following:
· Modify how errors and empty cells are displayed.
· Modify how items and labels without data are shown.
· Display or hide blank lines.
Modify the Format by doing the following:
Manually and conditionally format cells and ranges.
· Modify the overall PivotTable format style.
· Modify the number format for fields.
· Include OLAP Server formatting.
· You can automatically create a PivotChart report when you first create a PivotTable report, or you can create a PivotChart report from an existing PivotTable report.





UNIT - V
MS-Power Point
1. What is power point presentation?
A. A presentation is a collection of data and information that is to be delivered to a specific group of people. A PowerPoint presentation is a collection of electronic slides which can have text, pictures, graphics, tables, sound, and video.
2. What is Microsoft office button?
A. The Microsoft Office Button performs many functions as that of File menu of older versions of PowerPoint. This button allows you to create a new presentation, open an existing presentation, save and save as, print, send, or close.
3. What are the seven tabs in Ribbon in power point?
A. The ribbon is the panel located at the top of the document. It has seven tabs: Home, Insert, Design, Animations, Slide Show, Review and View. Each tab is divided into groups which have their respective tasks.
4. What is quick access toolbar?
A. The quick access toolbar is a customizable toolbar that contains commands that may allow you to use. The quick access toolbar can be placed above or below the ribbon.
5. What is mini toolbar?
A. A new feature in Office 2007 is the Mini Toolbar. This is a floating toolbar that is displayed when you select text or right-click text. It displays basic formatting tools,
such as Bold, Italics, Fonts, Font Size Color and Alignment.
6. What are the seven slide views in presentation views group in view tab?
A. These seven views are:
1.Normal
2. Slide Sorter
3. Notes Page
4. Slide Show
5. Slide Master
6. Handout Master
7. Notes Master
7. What are the themes?
A. Themes are design templates that can be applied to an entire presentation that allows for consistency throughout the presentation. To add a theme to a presentation:
1. Click on the Design tab
2. Choose one of the displayed Themes or click the Galleries button
8. What is a template?
A.     Template is a pattern or blueprint of a slide or group of slides. Templates can contain layouts, theme colors, theme fonts, theme effects, background styles, and even content.
9. Expand and write the concept of OLE?
A.OLE: Object Linking and Embedding.
            Object linking and embedding (OLE) is a Microsoft technology that facilitates the sharing of application data and objects written in different formats from multiple sources. An OLE object may display as an icon. Double clicking the icon opens the associated object application or asks the user to select an application for object editing.
10. What is meant by copy and move a text?
A.     When you make copy (copy and paste) it is present at both places source and destination. 
        When you make a move (cut and paste) it is present only at the destination and no more in the source.
11. What is meant by undo and redo?
A. The Undo feature is used to undo the previous action and the Repeat or Redo feature is used to repeat the previous action. For example, if you mistakenly delete text, you can use the Undo feature to recover it.
12. What is spell check?
A. Spell Check:
To check the spelling in a presentation:
· Click the Review tab
· Click the Spelling button.
13. What is word art?
A. WordArt is a quick way to make text stand out with special effects. You begin by picking a WordArt style from the WordArt gallery on the Insert tab, and then customize the text as you wish.
14. What are the four alignments?
A. 	Align Left: the text is aligned with your left margin.
Center: The text is centered within your margins.
Align Right: Aligns text with the right margin.
Justify: Aligns text to both the left and right margins.
15. What is indentation?
A. Indenting paragraphs allows you set text within a paragraph at different margins. There are several options for indenting:
First Line: Controls the left boundary for the first line of a 
                 paragraph.      
Hanging: Controls the left boundary of every line in a paragraph   
		except the first one.  
Left: Controls the left boundary for every line in a paragraph
Right: Controls the right boundary for every line in a paragraph
16. What are text directions?
A. Specify text direction in a shape or text box.
[image: Text direction samples: horizontal and rotated]




     
17. Expand AVI AND MPEG?
A. AVI: Audio Video Interleave.
    MPEG: Moving Picture Experts Group
18. What is clip art?
A. Clip art is a collection of pictures or images that can be imported into a document or another program.
19. What is Smart Art?
A. SmartArt is a way to turn ordinary text into something more visually appealing. It helps draw attention to important information or make information easier to interpret and understand.
20. What is Photo album?
A. PowerPoint allows you to import a set of pictures into a photo album presentation. With the photo album feature you can select, rearrange, adjust, and add text to your pictures.
21. What is a slide transition?
A.     A slide transition is how one slide is removed from the screen and the next slide is displayed during a presentation. 
      PowerPoint offers many entertaining and different slide transition schemes- the trick is to be careful not to use too many different schemes in one presentation.
22. What is a slide animation?
A. To add a special visual or sound effect to text or an object. For example, you can have your text bullet points fly in from the left, one word at a time, or hear applause when a picture is uncovered.
23. What is speaker’s note?
A. During your presentation, the speaker notes are visible on your monitor, but are not visible to the audience. So, the Notes pane is the place to store talking points that you want to mention when you give your presentation.
Long Answer Type Question
1. Write the groups in each tab of a ribbon in power point?
[bookmark: _Hlk73873339]A. The ribbon is the panel located at the top of the document. It has seven tabs: Home, Insert, Design, Animations, Slide Show, Review and View. Each tab is divided into groups which have their respective tasks.
      To view additional features within each group, select the arrow at the bottom right corner of each group.
Home: Clipboard, Slides, Font, Paragraph, Drawing, and Editing 
Insert: Tables, Illustrations, Links, Text, and Media Clips 
Design: Page Setup, Themes, Background
Animations: Preview, Animations, Transition to this Slide
Slide Show: Start Slide Show, Set Up, Monitors
Review: Proofing, Comments, Protect
View: Presentation Views, Show/Hide, Zoom, Window, Macros
2. Write the steps to create, save and preview a presentation?
A. Creating Presentation using Blank Presentation.
       you would get to know creation, saving and preview of presentation using blank.
New Presentation:
       A new presentation can be started from a blank slide, a template, existing presentations, or a Word outline. To create a new presentation from a blank slide:
· Click on the Microsoft Office Button
· Click on New.
· Click on Blank Presentation
To create a new presentation from an existing presentation:
· Click on the Microsoft Office Button
· Click on New.
· Click on New from Existing
Browse to and click the presentation.
To create a new presentation from a Word outline:
· Click on the slide where you would like the outline to begin.
· Click on New Slide on the Home tab
· Click on Slides from Outline
Browse and select the Word Document that contains the outline.
Save a Presentation:
When you save a presentation, you have two choices: Save or Save As. 
To save a document:
1.Click on the Microsoft Office Button
2.Click on Save
To use the Save As feature:
· Click on the Microsoft Office Button
· Click on Save As
· Type in the name for the Presentation
· In the Save as Type box, choose Excel 97-2003 Presentation.
Preview your presentation as a slide show:
To view your presentation on your computer screen exactly the way that it will look to your audience when you are presenting, do the following:
On the Slide Show tab, in the Start Slide Show group, do one of the following:
To start with the first slide in the presentation, click From Beginning.
To start with the slide that currently appears in the Slide pane, click From Current Slide
3. Write about formatting a text in power point?
A. Add and format text to organize content in your presentation.
Add text
1. Select a text placeholder or box.
2. Type in the text you want.
Format text
When you select text and choose a format, hover over a menu option to see a live preview in your slide.
Format options include:
· Font Color - Choose a font color for your text.
· Numbering or Bullets - Create a list using numbers or bullets.
· Add or Remove Columns - Add or remove columns in your text.
· Text Direction - Change the direction of text.
· Align Text - Connect your text to the top, middle, or bottom of a bounding box.
· Align Left, Center, Align Right, or Justify - Align your text the way you want.
· Increase List Level or Decrease List Level - Increase or decrease a list indent.
4. What are the steps to add video and audio to the presentation?
A. Inserting Audio in Presentations
    MS PowerPoint allows its users to add audio files and recordings to presentations to give a better look and feel to your slides.
Steps for Adding Audio:
There are some steps for inserting audio in the MS PowerPoint:
Step 1: Under the Insert tab, so many options are available where we can choose what feature we want to insert in their presentation. This may include images, audio, video, header, footer, symbols, shapes, etc.
Step 2: On the Insert tab, within the Media group click the Audio..
There are two ways of adding audio in the presentation:
(i) Audio on my PC  
(ii) Record Audio 
Step 3: Click on the “Audio on my pc” then this will open file explorer then you have to choose your Audio file.
             Choose the audio file that is to be added to the presentation.
Adding a Recorded Sound:
Step 4: Click on the Record Audio button:
Step 5: Click on the “Square Blue” button to stop recording it.
For Playing the audio, click on the green colored “Play” button.
The following steps will help you add video file to the slides.
Step 1 − Go to the Media group under the Insert ribbon.
Step 2 − To insert video file select Video as media type and Video from File to insert a video from your computer or hard drive.
Step 3 − In the Insert Video dialog, browse for a video file and click Insert.
Step 4 − You will now see that a Video file is added to the slide.
5. Write about graphics in power point?
A. To create effective slides, you need to add a few images, graphics or shapes.
1. Open your PowerPoint presentation. You can add graphics to the background of any slide in your PowerPoint presentation. Open the presentation you want to edit in PowerPoint.
2. Click the Design tab at the top of the window. This will display the Design tools.
3. Click the "Format Background" button. You'll find this on the far-right side of the Design ribbon. The Format Background sidebar will appear on the right side of the screen.
4. Select the slides you want to apply the background to. By default, your background changes will only apply to the active slide. You can hold Ctrl / ⌘ Command and click each slide in the slide list on the left that you want to select.
5. Select "Picture or texture fill." This will allow you to select a picture to use as the background.
6. Choose the image that you want to insert as the background. To add an image that will not be stretched or squished, it should be 1280 x 720 pixels in size.
7. Click "Apply to All" to set the picture for all slides. The picture is normally just added as the background for the slides you selected. 
8.If you want to apply it to every slide, click the "Apply to All." This will set the background of every slide to the new image, including slides that you create later.
6. Write the steps for animation of slides?
A.       In PowerPoint you have an option called animate which is used to animate the text and objects such as clip art, shapes, and pictures.
To add animation effects in a PowerPoint slide, follow the steps below.
1. Open a new or existing PowerPoint slide deck.
2. In a slide, add and highlight the text or image you want to animate.
3. In the Ribbon, click the Animations tab.
4. On the Animations tab, in the Advanced Animation section, click the Add Animation option.
Select the desired type of animation effect. You can select an Entrance, Emphasis, and Exit animation effect. You can also select a Motion Path effect if you want to change the motion path of the animation.
7. What are handout and notes page?
A. The Handout Master
             Masters are an assistant to create patterns. Everything is duplicated based on elements existing in the master. 
             Unlike slides, Handouts are almost always proposed for print and title.etc. so it better to edit the Handout Master based on that assumption. 
              You want to be sure of using content that prints well to both black and white and colored output.
To edit the Handout Master,

· go to View.
· click on Master.
· Select Handout Master.
To format handout pages:
1. Choose View -> Master -> Handout Master or hold down Shift as you click the Slide Sorter View button.
2. The Handout Master appears
3. On the Handout Master View toolbar, choose the icon that represents the number of slides you want to appear on each handout page.
4. Make any of the following changes:
5.To add text that you want to appear on each page (such as the presentation title or page number), choose the View > Header and Footer command.
6.Add any desired background graphics.
7.When you are finished, click Close on the Handout Master View toolbar.
Notes Page view
        It is not one of the view commands included at the bottom of Normal view; however, it can be selected from the View tab. This view provides a space for presentation notes, which are often called speaker notes.
To change to Notes Page view:
· Select the View tab.
· Locate the four view commands on the left side of the Presentation Views group.

· Click Notes Page view.
8. Write about the printing of a presentation?
A. Print your presentation.
1. Select File > Print.
2. For Printer, select the printer you want to print to.
3. For Settings, select the options you want:
· Slides: From the drop-down, choose to print all slides, selected slides, or the current slide. Or, in the Slides box, type which slide numbers to print, separated by a comma.
· Print Layout: Choose to print just the slides, just the speaker notes, an outline, or handouts.
The Outline prints only the text in the slides, without images. The Notes of a presentation show the slide and the related speaker notes below it. If you choose to print Handouts, you can print several slides on one page using a variety of layouts, some with space for note-taking.
· Collated: Choose whether you want the sheets collated or uncollated.
· Color: Choose whether you want color, grayscale, or pure black and white.
· Edit Header & Footer: Select to edit the header and footer before printing.
4. For Copies, select how many copies you want to print.
5. Select Print.
9. Discuss about animation of objects?
A. In PowerPoint you have an option called animate which is used to animate the text and objects such as clip art, shapes, and pictures.
Animating text and objects
        In PowerPoint we have variety of animations which are used to enhance your presentation. To create customized animation, you can use motion paths.
To apply an animation to an object:
1. Select an object.
2. Select the Animations tab.
3. In the Animation group, press the More drop-down arrow to view all the available animations.
4. Select the desired animation effect.
5. The object will now have a small number next to it which indicates that the object is animated. Also, in the Slide pane, the slide will now have a star below the number of that slide.
At the bottom of the menu, you can also access more effects.
To add multiple animations to an object:
           If you select a new animation for an object from the menu in the Animation group, it will replace the object's current animation.
1. Select the object.
2. Press the Animations tab.
3. In the Advanced Animation group, select the Add Animation command to view the available animations.
4. Choose the desired animation effect.
To preview animations:
All the animation affects you have applied to the presentation will be shown up when you play the slide show. However, you can also quickly preview the animations of a particular slide without viewing the slide show.
1. Navigate to the slide you want to preview the animation effects.
2. From the Animations tab, select the Preview command. Then the animation effects for the current slide will play.
10. Discuss the concept of drawing freeform shapes?
A. You can draw different shapes in PowerPoint 2010 by the help of freeform Shape and
Scribble tools.
5.1.2 To draw a freeform shape:
1. Go to the Insert tab select the Illustrations group and click on the Shapes option.
2. To draw a shape that has both curved and straight segments, click Freeform.
3. To draw a shape that looks like it was drawn with a pen by hand, or to create smooth curves, click Scribble and click anywhere in the document, and then drag to draw.
4. To draw a straight segment with the freeform tool, click one location, move your pointer to a different location, and then click again; to draw a curved segment, keep your mouse button pressed as you drag to draw.
To finish drawing the shape, do one of the following
· To leave the shape open, double-click at any time.
· To close the shape, click near its starting point.

Edit points in a shape
You can edit the points of most shapes. For example, you edit points when you need to lean a triangle over to the right.
1. Select the shape that you want to edit and go to the Format tab, click Edit Shape, and then select Edit Points.
2. Drag one of the vertexes that outline the shape. A vertex is the point, indicated by a black dot, where a curve ends or the point where two-line segments meet in a freeform shape.
11. Explain the concept of OLE?
A. Inserting OLE- Object Linking and Embedding
         You can use hyperlinks to move from one slide to another, to a network or Internet location, or even to another file or program altogether.
· Select the text that you want to click to activate the hyperlink. Alternatively, you can select an object (a piece of clip art, for example, or a SmartArt graphic)
· On the Insert tab, in the Links group, click Hyperlink.
· In the Insert Hyperlink dialog box, click the appropriate button in the My Places box for the target of your link (that is, the place where the link takesyou).
· To go to another slide in your presentation, for example, click Place inThis Document.
· Find and click the target location, make any changes that you want in the Text to display and Address boxes, and then click OK.
12. Write the steps for rotating objects?
A. Rotating Objects
       In PowerPoint, every slide may have different items, such as pictures, shapes, and text boxes. PowerPoint lets you arrange the objects the way you want by aligning, grouping, rotating, and ordering them in multiple ways.
       After adding objects to a slide, it is necessary to arrange them, so the objects appear the way you want. You can align, group, rotate, and order objects to create the desired arrangement.
Aligning objects:
        PowerPoint provides you with various commands that allow you to arrange and position objects easily.
To align two or more objects:
1. Click and drag the mouse to form a selection box around the objects you want to align. All the objects will now have sizing handles to show that they are selected.
2. From the Format tab, select the Align command, and then select Align Selected Objects.
3. Click on the Align command again, and select one of the six alignment options.
4. The objects will align to each other based on the selected option.
To rotate an object:
1. Select an object. The Format tab will appear.
2. From the Format tab, select the Rotate command. A drop-down list will appear.
3. Click on the desired rotation option.

THE END


“HARD WORK IS SECRET OF SUCCESS”
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